TASKS:
  1. Configure IP addresses on R1 and R2 as per topology
  2. Configure Loopback interface on R2 10.1.1.1/32
  3. Configure 1.1.1.0 as primary static route
  4. Configure 1.1.2.0 as floating static route
  5. Verify results by shutting down primary route interface of R1, R2 and both.
! Configuration of R1
hostname R1

interface FastEthernet0/0
ip address 1.1.2.1 255.255.255.0
no shut

interface FastEthernet0/1
ip address 1.1.1.1 255.255.255.0
no shut

ip route 10.1.1.1 255.255.255.255 1.1.1.100
ip route 10.1.1.1 255.255.255.255 1.1.2.50 15


! Configuration of R2
hostname R2

interface Loopback0
ip address 10.1.1.1 255.255.255.255

interface FastEthernet0/0
ip address 1.1.2.50 255.255.255.0
no shut

interface FastEthernet0/1
ip address 1.1.1.100 255.255.255.0
no shut
Explanation










Primary Static route with default Administrative distance
Floating Static route with administrative distance of 15

Verification

R1#show ip route
     1.0.0.0/24 is subnetted, 2 subnets
C       1.1.1.0 is directly connected, FastEthernet0/1
C       1.1.2.0 is directly connected, FastEthernet0/0
     10.0.0.0/32 is subnetted, 1 subnets
S       10.1.1.1 [1/0] via 1.1.1.100

Shut down R1 primary route interface and check routing table now

R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            1.1.2.1         YES manual up                    up
FastEthernet0/1            1.1.1.1         YES manual administratively down down

R1#sh ip route

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.2.0 is directly connected, FastEthernet0/0
     10.0.0.0/32 is subnetted, 1 subnets
S       10.1.1.1 [15/0] via 1.1.2.50

 
Picture
TASKs:
  1. Confiigure IP addresses as per diagram
  2. Configure static ip address on R1 to reach network 2.2.2.0 and Default IP address on R3 to reach network 1.1.1.0

! R1 Configuration
hostname R1

interface FastEthernet0/0
 ip address 1.1.1.1 255.255.255.252
no shut

ip route 2.2.2.0 255.255.255.252 1.1.1.2


! R2 Configuration
hostname R2

interface FastEthernet0/0
 ip address 1.1.1.2 255.255.255.252
no shut

interface FastEthernet0/1
 ip address 2.2.2.1 255.255.255.252
no shut


! R3 Configuration
hostname R3

interface FastEthernet0/0
 ip address 2.2.2.2 255.255.255.252
no shut

ip route 0.0.0.0 0.0.0.0 2.2.2.1



Changing hostname to R1


Assigning ip address to an interface


Configuring static ip address on R1 to reach 2.2.2.0 network via next-hop 1.1.1.2





















Configuring Default ip address on R3 to reach 1.1.1.0 network via 2.2.2.1 Hop
Verification of routes

R1#show ip route

     1.0.0.0/30 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, FastEthernet0/0
     2.0.0.0/30 is subnetted, 1 subnets
S       2.2.2.0 [1/0] via 1.1.1.2


R2#show ip route

     1.0.0.0/30 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, FastEthernet0/0
     2.0.0.0/30 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, FastEthernet0/1


R3#show ip route

Gateway of last resort is 2.2.2.1 to network 0.0.0.0

     2.0.0.0/30 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 2.2.2.1

Verification via Ping

R1#ping 2.2.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/90/152 ms


R1#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/96/232 ms

Show controllers

6/16/2013

 
Picture

1. Show controllers
This command will show full hardware level controller information of all attached interfaces.

2. Show controllers serial 0/0
This command will show full hardware level controller information for interface serial 0/0 only
.
3. Show controllers fastethernet 0/0
This command will show full hardware level controller information for interface fastethernet 0/0 only

 
Picture














R2#show version

CCNA Basic Lab 1

6/15/2013

 
Picture
 Requirement
  1. Change hostname of R1 to USA-Router
  2. Configure password on console
  3. Configure login name and password on console
  4. Configure enable password
  5. Configure enable secret
  6. Configure ip addresses on both routers interfaces
  7. Configure password for Telnet
  8. Configure login name and password for telnet

R1 configuration
R1>enable           

R1#            
       
R1# configure terminal    

R1(config)# 
       
R1(config)# hostname USA-Router

USA-Router(config)#
USA-Router(config)#Line console 0
USA-Router(config-line)#password cisco
USA-Router(config-line)#login


USA-Router#exit
USA-Router#configure terminal
USA-Router(config)#username irfan password mypass
USA-Router(config)#line console 0
USA-Router(config-line)#login local






USA-Router#exit

USA-Router(config)#enable password mypassword



USA-Router(config)#enable secret mysecret




USA-Router(config)#interface fastethernet 0/0
USA-Router(config-if)#ip address 1.1.1.1 255.255.255.252
USA-Router(config-if)#no shutdown



USA-Router(config)#line vty ?
  <0-1340>  First Line number


USA-Router(config)#line vty 0 4


USA-Router(config-line)#password vtypass
USA-Router(config-line)#login local
USA-Router(config-line)#no login local

USA-Router(config-line)#login



Router 2 configuration
R2#configuration terminal
R2(config)#int fastEthernet 0/0
R2(config-if)#no shutdown
R2(config-if)#ip address 1.1.1.2 255.255.255.252
R2(config-if)# Ctrl+c or exit
R2#telnet 1.1.1.1
Command Help
(This command Let you enter privileged or enable mode)
( > signifies user mode and # signifies that you are in enable mode)
(This command Let you enter in configuration mode; You can only do configuration in this mode)
(config)# signifies that you are in global configuration mode
hostname command let you change host name from R1 to USA-Router
Please notice that hose name has changed
Entering into console line
Putting password on console line
login command let router ask for password when you try to enter via console. Let's check by exiting our of our router and try to re-enter.
Exiting from router

After giving exit command, and couple of enters. You will be prompted for password. This is a console password we just set.

Please note that for security reasons your typed password will not show anything on screen; so don't get confused while working.


Enter into configuration mode
Set username and password for into router

This command let you get into line console 0
Please look into it and try to recall; Last time when we have just given password to console; Our command was just "login" but now we have written "login local". Login local let router know that now from onward it will ask for username as well as password (User based authentication).

Let exit from router and try to find out if there is any difference.


Have you noticed any difference. Look under

1) Router is asking for user as well as password
2) When you have given user and password, it has just thrown you into user mode rather enable mode (look into previous image).



Setting password to enter into enable mode.
Try to exit from router and check; This time it will not let you in enable mode without password.

Secret is an encrypted password. If you have set both password and secret. Secret will take precedence. However; you will find both in your router configuration file.

Enter into interface f0/0 for ip addressing
ip address has been given with mask

By default, Router interface are shutdown so if you want them workable then give this command.


? is a great help, when you need to find any command or its portion put question mark. Here it shows how many line vty (telnet) line we have

This command will let us in vty line 0 to 4. means now what so we do, it will get applied on only line 0 to 4.
Set password on vty lines 0 to 4
login local tell router to ask for user and password
if we put "no" before any command that command will get deleted or non-effective.
login let router ask for only password we set.



Router 2 configuration starts
Enter into configuration terminal
entering into interface f0/0
opening shutdown interface
giving ip address to interface
exiting from interface mode to enable mode
Let's telnet our router 1's interface fastethernet 0/0 ip address 1.1.1.1.

Telnet result shows that router 1 is asking for password due to "login" command on vty lines. if we configure "login local" command, router will ask for user and password.

When we have given vty lines password. Look we have enter into USA-Router. Now we can configure or look into USA-Router configuration as per privileges
.
Check to verify


 
Picture
Controller commands:

1. show controllers
2. show controllers serial 0/0
3. show controllers fastethernet 0/0









R2#show controllers                                      This command show full hardware level detailed information of all interfaces controllers

R2#show controllers serial 0/0                      This will only show specific hardware controller information related to  serial 0/0
R2#show controllers fastethernet 0/0            This will only show specific hardware controller information related to  f 0/0

Please find both commands outpt